Send button displays "please wait"

  1. 2 months ago

    I have this problem on my existing Mautic installation. No forms are working correctly anymore. When you click on the send button it will display only "please wait...".

    It look like the form is workin. The data is in the Mautic database. Also email are send. But the form freeze with a send button that display “please wait”

    To make sure I upgraded Mautic to the latest version: Mautic v 2.10.1

    To fix this I have tried:

    • I have run: php app/console mautic:assets:generate
    • clear my cache: rm -rf ./app/cache/*
    • rebuild my forms

    Nothing works.

    Any advice?

  2. change the code , i mean what code you using , HTML, Iframe or Java?

  3. Edited 2 months ago by ronald_d

    @bizcrony In mautic I go to Preview form. Then I tried to submit a form to test if it work correctly.

  4. Hi @bizcrony , I have also made a test page now. I use this code in the test.html page:
    <script type="text/javascript" src="https://mydomain/mautic/form/generate.js?id=12"></script>

  5. I have the exact same issue. I have reinstalled Mautic - tried every fix I can find in the forums - cleared cache - rebuilt forms - even installed a second version of Mautic 2.10.1 - Nothing fixes the forms.

  6. Please share the screenshot . where its appearing ?

  7. Edited 2 months ago by Jim

    "Please wait..." appears on the Send button replacing whatever text I had put there. I just reinstalled 2.10.1 hoping that a fresh install would fix the problem, but no such luck. I create the webpage and form in Mautic so the problem is all Mautic. I have tested putting the form in a page on a different site, but the form does the same no matter if it is a Mautic site or a different site on a different domain.

    Incidentally, I have an account on mautic.net and the forms work there! That makes me wonder if the issue is an environmental issue with php ? I am using PHP Version 7.0.21.

    Whoops! I finally found the fix over at GitHub. My forms now work - at least from an incognito browser! That is a huge step forward.

  8. Temp solution is here

    link text

  9. Already reported ten times on the forum, no fix so far. Except the link provided by Robmobius.

  10. Hello Guys,

    I have found a solution for this problem.

    There is a problem on GitHub about this, see: https://github.com/mautic/mautic/issues/4287

    To fix this I downloaded the latest mautic-form.js and mautic-form-src.js from https://github.com/marcel-ambta/mautic/tree/b2209e840d27b809967bd1fc1ec4cc64aa2ff9c4/media/js and put these files into your own installation ../mautic/media/js/

    After this the forms buttons works correctly for me.

 

or Sign Up to reply!