2.6.1 Released!

  1. 3 months ago

    alanhartless

    Feb 16 Administrator
    Edited 3 months ago by alanhartless

    This is a bug fix release. Read the full release notes here.

    If upgrading from earlier than 2.6.0:
    If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it with php upgrade.php. Be sure to remove this file once the upgrade is complete.

    If upgrading from 2.6.0:
    Since this does not include any schema changes, the update process built into Mautic's front-end will suffice in updating. Simply log out, back in, and you should see the upgrade notification similar to:

    -image-

    Click Update Now and follow the prompts.

    Happy Marketing!

    The Mautic Team

  2. OK I have not much to loose yet. Went ahead and applied the update. Though clearing cache wheel is still spinning for sometime... like 5 minutes.

    Eeee!

    Lets see what comes out of it!

    Thanks!

  3. And its still spinning. I went ahead and opened the dashboard in a new window by right clicking. Everything seems fine. Footer changed to 2.6.1

  4. Edited 3 months ago by Hasaan

    Contacts broken - 500 error

    Please refer to this post for error log messages: https://www.mautic.org/community/index.php/6951-2-6-1-update-contacts-broken-500-error

    Thanks

  5. alanhartless

    Feb 16 Administrator

    @Hasaan what version are you upgrading from?

  6. @alanhartless @Hasaan what version are you upgrading from?

    2.6.0

  7. Hi. I've upgraded to 2.6.1, from 2.6.0, and it gives the offline message, even after delete the cache. During upgrade on the clean cache task, it gives an error and goes offline and stays.

    "The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator."

    [2017-02-16 23:48:42] mautic.WARNING: PHP Warning - require(/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php): failed to open stream: No such file or directory - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
    [2017-02-16 23:48:42] mautic.ERROR: PHP Notice: require(): Failed opening required '/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php' (include_path='.:/opt/bitnami/php/lib/php') - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
    [2017-02-16 23:48:42] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required '/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php' (include_path='.:/opt/bitnami/php/lib/php') - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

  8. That's a cache permission problem. Either delete the cache/prod folder and refresh Mautic via the browser or run the console cache:clear command as the web server user.

  9. Edited 3 months ago by edulrc

    The cache folder has been deleted already, several times, but the error persistis.

  10. What user is the web server running under and does that user own all the directories and files under /opt/bitnami?

  11. Update failed.
    Version on Server 2.5.1
    Update to 2.61

    Here the Error on Console:

    lichtebs@vmd16158:~/newsletter.lichte-kraft.eu/app$ /usr/local/pd-admin2/bin/php-7.0-cli console mautic:update:find
    Version 2.6.1 von Mautic ist zum Download bereit. Weitere Informationen finden Sie hier: https://mautic.org/community/index.php/6945-2-6-1-released .
    Verwenden Sie 'php app/console mautic:update:apply' auf der Kommandozeile um zu aktualisiern.
    lichtebs@vmd16158:~/newsletter.lichte-kraft.eu/app$ /usr/local/pd-admin2/bin/php-7.0-cli console mautic:update:apply
    Sind Sie sicher, dass Sie Mautic zur neuesten Version aktualisieren möchten? Y
    Step 6 [------>---------------------] Cache löschen

    [Symfony\Component\Debug\Exception\FatalThrowableError]
    Type error: Argument 1 passed to Mautic\CoreBundle\Helper\CacheHelper::__construct() must be an instance of AppKernel, instance of Mautic\CoreBundle\Fac
    tory\MauticFactory given, called in /home/lichtebs/newsletter.lichte-kraft.eu/app/cache/prod/appProdProjectContainer.php on line 10180

    mautic:update:apply [--force] [-p|--update-package [UPDATE-PACKAGE]] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-s|--shell] [--process-isolation] [-e|--env ENV] [--no-debug] [--] <command>

  12. Any thing on my issue guys?

  13. My upgrade failed first attempt too. from 2.5.1.

    Checking for new updates...updating to 2.6.1!
    Extracting the update package...done!
    Moving files...done!
    Clearing the cache...done!
    Rebuilding the cache...done!
    Applying migrations...failed. Review udpate errors log for details.

    As far as I can tell the important part of the logs is:
    Column not found: 1054 Unknown column 'l0_.timezone' in 'field list'
    Column not found: 1054 Unknown column 't0.timezone' in 'field list'

    I followed another procedure linked off this page (https://www.mautic.org/community/index.php/6951-2-6-1-update-contacts-broken-500-error). Upgrade then worked.

    After the upgrade the avatar icon is broken. It's pointing to:
    ma/ma/media/images/avatar.png
    (where my install dir is /ma. I'll live with that)

    Although when using an embedded iframe form on a wordpress page, when the form is completed it now loads the target page inside the iframe on the original page.

  14. Edited 3 months ago by Ashwini Hinduja

    After upgrading from 2.0.1 to 2.6.1, I found bug in contact section.

    While adding notes to a contact, it displays incorrect count and also when trying to delete the note, it displays the delete code.

    Could you please suggest me, how to sort out.

  15. 2 months ago
    Edited 2 months ago by MaskOfMint

    Upgrading from 2.6.0 to 2.6.1 failed. The log shows the following:

    [2017-02-26 21:37:24] mautic.NOTICE: PHP Notice - Undefined index: package - in file /var/www/vhosts/mydomain/app/bundles/CoreBundle/Controller/AjaxController.php - at line 374 [] []
    [2017-02-26 21:37:24] mautic.ERROR: An error occurred while attempting to fetch the package: malformed [] []

  16. "php upgrade.php
    Checking for new updates...failed. Could not automatically download the package. Please download https://s3.amazonaws.com/mautic/releases/2.6.1-update.zip , place it in the same directory as this upgrade script, and try again."
    Seems the file doesn't exist.
    I tried to download it manually without success.
    Any help?
    Best wishes,
    Lucas

  17. Edited 2 months ago by lucasmmendes

    Error discovered. Amazon S3 US1-east was with errors. They fixed the S3 access.
    Upgrade 2.5.1 to 2.6.1 done using ssh and upgrade.php but with errors in database. I used the https://johnlinhart.com/blog/uh-oh-mautic-upgrade-was-not-successful to fix it. Done.
    Thank you very much.
    Best wishes,
    Lucas

 

or Sign Up to reply!